summaryrefslogtreecommitdiffstats
path: root/tests/auto/wasm/CMakeLists.txt
diff options
context:
space:
mode:
authorMikolaj Boc <mikolaj.boc@qt.io>2023-06-14 14:54:34 +0200
committerMikolaj Boc <mikolaj.boc@qt.io>2023-06-15 09:41:06 +0200
commitfc4fca6d9dc22839ca73898c362faff96c81214c (patch)
treea30fcc5804cf28f81631f970d54e2c6207549f9a /tests/auto/wasm/CMakeLists.txt
parenteb92d52dc7190efefae0fae89c7c6eb9e16cdd9d (diff)
Support child windows on WASM
Setting parents for WASM platform windows is now supported. This means that windows now reside in a hierarchical window tree, with the screen and individual windows being nodes (QWasmWindowTreeNode), each maintaining their own child window stack. The divs backing windows are properly reparented in response to Qt window parent changes, so that the html structure reflects what is happening in Qt. Change-Id: I55c91d90caf58714342dcd747043967ebfdf96bb Reviewed-by: Morten Johan Sørvig <morten.sorvig@qt.io>
Diffstat (limited to 'tests/auto/wasm/CMakeLists.txt')
-rw-r--r--tests/auto/wasm/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/auto/wasm/CMakeLists.txt b/tests/auto/wasm/CMakeLists.txt
index 47031037e0..0d67ae8e79 100644
--- a/tests/auto/wasm/CMakeLists.txt
+++ b/tests/auto/wasm/CMakeLists.txt
@@ -30,6 +30,19 @@ qt_internal_add_test(tst_qwasmwindowstack
Qt::Widgets
)
+qt_internal_add_test(tst_qwasmwindowtreenode
+ SOURCES
+ tst_qwasmwindowtreenode.cpp
+ DEFINES
+ QT_NO_FOREACH
+ LIBRARIES
+ Qt::GuiPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Widgets
+)
+
qt_internal_add_test(tst_qwasmkeytranslator
SOURCES
tst_qwasmkeytranslator.cpp