summaryrefslogtreecommitdiffstats
path: root/tests/auto/wasm/localfileapi/CMakeLists.txt
diff options
context:
space:
mode:
authorMorten Sørvig <morten.sorvig@qt.io>2024-04-12 10:25:49 +0200
committerMorten Sørvig <morten.sorvig@qt.io>2024-04-15 19:28:47 +0200
commit8ba043cbaf38f9cddaa9d557c503ef4e3f5cbac3 (patch)
tree891153501d05e66951d8f51e3534b3bcbd07b058 /tests/auto/wasm/localfileapi/CMakeLists.txt
parent9fd895e3c1c0472a2b43c7935a9c3ae168ab7080 (diff)
wasm: move wasm tests to own subdirectories
Match the standard one-test-per-directory setup. Change-Id: I0e29e3c5626ef5f739b1680d53a2a74f0c77f9be Reviewed-by: Piotr Wierciński <piotr.wiercinski@qt.io> Reviewed-by: Jøger Hansegård <joger.hansegard@qt.io>
Diffstat (limited to 'tests/auto/wasm/localfileapi/CMakeLists.txt')
-rw-r--r--tests/auto/wasm/localfileapi/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/auto/wasm/localfileapi/CMakeLists.txt b/tests/auto/wasm/localfileapi/CMakeLists.txt
new file mode 100644
index 0000000000..efb29ad48c
--- /dev/null
+++ b/tests/auto/wasm/localfileapi/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_localfileapi Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_localfileapi LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_localfileapi
+ SOURCES
+ tst_localfileapi.cpp
+ DEFINES
+ QT_NO_FOREACH
+ LIBRARIES
+ Qt::GuiPrivate
+ Qt::Core
+ Qt::Gui
+ Qt::Widgets
+)