summaryrefslogtreecommitdiffstats
path: root/tests/auto/widgets/itemviews/qdirmodel/CMakeLists.txt
diff options
context:
space:
mode:
authorVolker Hilsheimer <volker.hilsheimer@qt.io>2020-06-03 11:26:24 +0200
committerVolker Hilsheimer <volker.hilsheimer@qt.io>2020-06-04 19:11:19 +0200
commit94dcb5454f0f8f144568dff7a9dd1316046ee197 (patch)
tree7da0e7c6708999abc9b4cd88ee7e83aa996b18e2 /tests/auto/widgets/itemviews/qdirmodel/CMakeLists.txt
parent5781ef2013160ba3810ad7df399aa79be085cd6c (diff)
Remove the deprecated QDirModel
QFileSystemModel is the documented replacement. It uses threads to populate the model, which QDirModel doesn't. Change-Id: I7818ecd8f849eb566ac176612f382e17a0471c47 Reviewed-by: Lars Knoll <lars.knoll@qt.io> Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'tests/auto/widgets/itemviews/qdirmodel/CMakeLists.txt')
-rw-r--r--tests/auto/widgets/itemviews/qdirmodel/CMakeLists.txt49
1 files changed, 0 insertions, 49 deletions
diff --git a/tests/auto/widgets/itemviews/qdirmodel/CMakeLists.txt b/tests/auto/widgets/itemviews/qdirmodel/CMakeLists.txt
deleted file mode 100644
index d47cc3457d..0000000000
--- a/tests/auto/widgets/itemviews/qdirmodel/CMakeLists.txt
+++ /dev/null
@@ -1,49 +0,0 @@
-# Generated from qdirmodel.pro.
-
-#####################################################################
-## tst_qdirmodel Test:
-#####################################################################
-
-add_qt_test(tst_qdirmodel
- SOURCES
- ../../../../shared/emulationdetector.h
- tst_qdirmodel.cpp
- INCLUDE_DIRECTORIES
- ../../../../shared
- PUBLIC_LIBRARIES
- Qt::Gui
- Qt::Widgets
-)
-
-## Scopes:
-#####################################################################
-
-extend_target(tst_qdirmodel CONDITION ANDROID
- DEFINES
- SRCDIR=\\\"./\\\"
-)
-
-extend_target(tst_qdirmodel CONDITION NOT ANDROID
- DEFINES
- SRCDIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/\\\"
-)
-
-if(ANDROID AND NOT ANDROID_EMBEDDED)
- # Resources:
- set(testdata_resource_files
- "dirtest/test1/dummy"
- "dirtest/test1/test"
- "test/file01.tst"
- "test/file02.tst"
- "test/file03.tst"
- "test/file04.tst"
- "tst_qdirmodel.cpp"
- )
-
- add_qt_resource(tst_qdirmodel "testdata"
- PREFIX
- "/android_testdata"
- FILES
- ${testdata_resource_files}
- )
-endif()