summaryrefslogtreecommitdiffstats
path: root/tests/auto/widgets/kernel/qwidget/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-05-02 09:33:45 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-05-02 07:37:13 +0000
commit94c9d15355e07113da693f067c1ac15e5f7dc8d7 (patch)
tree2fca75579f3c58e008c91c05d538c24ba70cc12b /tests/auto/widgets/kernel/qwidget/CMakeLists.txt
parentbcfc3dca5d9f3e329fbbcf114145cf8b348c2c81 (diff)
Re-generate CMakeListst for some tests that use .qrc files
This way we don't need to run rcc during cmake time Change-Id: Id92111bce6c2b6798f3b18552cea82c8d07c4fc0 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/widgets/kernel/qwidget/CMakeLists.txt')
-rw-r--r--tests/auto/widgets/kernel/qwidget/CMakeLists.txt46
1 files changed, 39 insertions, 7 deletions
diff --git a/tests/auto/widgets/kernel/qwidget/CMakeLists.txt b/tests/auto/widgets/kernel/qwidget/CMakeLists.txt
index 3bafe782d6..86d02ac733 100644
--- a/tests/auto/widgets/kernel/qwidget/CMakeLists.txt
+++ b/tests/auto/widgets/kernel/qwidget/CMakeLists.txt
@@ -1,16 +1,48 @@
-add_qt_test("tst_qwidget"
+# Generated from qwidget.pro.
+
+#####################################################################
+## tst_qwidget Test:
+#####################################################################
+
+add_qt_test(tst_qwidget
SOURCES
- qwidget.qrc
tst_qwidget.cpp
LIBRARIES
- Qt::Widgets
Qt::CorePrivate
Qt::GuiPrivate
- Qt::WidgetsPrivate
Qt::TestPrivate
+ Qt::WidgetsPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Test
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(tst_qwidget "qwidget" FILES
+ geometry-fullscreen.dat
+ geometry-maximized.dat
+ geometry.dat)
+
+
+#### Keys ignored in scope 1:.:.:qwidget.pro:<TRUE>:
+# CONFIG = "testcase" "x11inc"
+# testcase.timeout = "600"
+
+## Scopes:
+#####################################################################
+
+extend_target(tst_qwidget CONDITION APPLE_OSX
+ SOURCES
+ tst_qwidget_mac_helpers.mm
+ PUBLIC_LIBRARIES
+ ${FWAppKit}
+ ${FWSecurity}
)
-extend_target("tst_qwidget" CONDITION APPLE_OSX
- SOURCES tst_qwidget_mac_helpers.mm
- LIBRARIES ${FWSecurity} ${FWAppKit}
+extend_target(tst_qwidget CONDITION WIN32 AND NOT WINRT
+ PUBLIC_LIBRARIES
+ gdi32
+ user32
)