summaryrefslogtreecommitdiffstats
path: root/tests/benchmarks/corelib/text/qutf8stringview/CMakeLists.txt
diff options
context:
space:
mode:
authorØystein Heskestad <oystein.heskestad@qt.io>2022-11-22 17:48:45 +0100
committerØystein Heskestad <oystein.heskestad@qt.io>2022-12-02 11:35:49 +0100
commitb977ae371a753a82e1d0bb32c5b62099da663721 (patch)
tree895d517f35c5a961781c156cf8c23857d688de6c /tests/benchmarks/corelib/text/qutf8stringview/CMakeLists.txt
parent724329b79ea8bf00cc4b393fa33d91d477b35497 (diff)
Add In-place utf-8 case-insensitive comparisons
Also add optimizations for more string comparisons and add tests and benchmarks. [ChangeLog][QtCore][QString] Added utf-8 case-insensitive comparisons Fixes: QTBUG-100235 Change-Id: I7c0809c6d80c00e9a5d0e8ac3ebb045cf7004a30 Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'tests/benchmarks/corelib/text/qutf8stringview/CMakeLists.txt')
-rw-r--r--tests/benchmarks/corelib/text/qutf8stringview/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/benchmarks/corelib/text/qutf8stringview/CMakeLists.txt b/tests/benchmarks/corelib/text/qutf8stringview/CMakeLists.txt
new file mode 100644
index 0000000000..14613afe56
--- /dev/null
+++ b/tests/benchmarks/corelib/text/qutf8stringview/CMakeLists.txt
@@ -0,0 +1,14 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_bench_qutf8stringview Binary:
+#####################################################################
+
+qt_internal_add_benchmark(tst_bench_qutf8stringview
+ SOURCES
+ tst_bench_qutf8stringview.cpp
+ LIBRARIES
+ Qt::Test
+ Qt::CorePrivate
+)