summaryrefslogtreecommitdiffstats
path: root/tests/benchmarks/corelib/thread/CMakeLists.txt
diff options
context:
space:
mode:
authorSona Kurazyan <sona.kurazyan@qt.io>2021-06-10 10:20:03 +0200
committerSona Kurazyan <sona.kurazyan@qt.io>2021-06-19 08:48:14 +0200
commit72e21ad3e9f51acfe5da83ebeb859452266a3cf4 (patch)
treef22cd8519105c667c4f1fcad1b4e0b3f8c8e7485 /tests/benchmarks/corelib/thread/CMakeLists.txt
parent95de42212405aea45b17f2d9c500b6af097dee3e (diff)
Add basic benchmarks for QFuture
The benchmark simply calls the non-trivial methods of QFuture, mostly to make sure that fixes in the parent patches don't have any performance implications. Task-number: QTBUG-92045 Change-Id: Ib4e8c314a70b3090a1af55f1b96d9dad4bc63861 Reviewed-by: Andrei Golubev <andrei.golubev@qt.io>
Diffstat (limited to 'tests/benchmarks/corelib/thread/CMakeLists.txt')
-rw-r--r--tests/benchmarks/corelib/thread/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/benchmarks/corelib/thread/CMakeLists.txt b/tests/benchmarks/corelib/thread/CMakeLists.txt
index dc257262a3..8f7b829a40 100644
--- a/tests/benchmarks/corelib/thread/CMakeLists.txt
+++ b/tests/benchmarks/corelib/thread/CMakeLists.txt
@@ -1,5 +1,6 @@
# Generated from thread.pro.
+add_subdirectory(qfuture)
add_subdirectory(qmutex)
add_subdirectory(qreadwritelock)
add_subdirectory(qthreadstorage)