summaryrefslogtreecommitdiffstats
path: root/tests/benchmarks/corelib/tools/qcryptographichash/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Welbourne <edward.welbourne@qt.io>2021-08-18 11:48:29 +0200
committerEdward Welbourne <edward.welbourne@qt.io>2021-08-30 19:21:08 +0200
commit9004a2412ba1f9976c2c61f01223dff852208c42 (patch)
treef06abeec8b9cc66abf0e66cc9048c7a0ed02a360 /tests/benchmarks/corelib/tools/qcryptographichash/CMakeLists.txt
parentc2a6749af795386495b275684418d083410fa1e4 (diff)
Standardise layout and naming in corelib benchmarks
Make file names match CMake's test names (and those follow dir-name) and class names follow tst_ClassName pattern when testing ClassName. Purge comments about the qmake configs the CMakeLists.txt are generated from. Purge empty constructors and init/cleanup methods of classes. Fix petty coding style violations. Add qdir/tree/, qurl, qbench and qset benchmarks to their parent directories' lists of subdirs. Fix unused return error from qurl benchmark. Change-Id: Ifc15a3a46e71cf82ad0637753517e0df34049763 Reviewed-by: Andrei Golubev <andrei.golubev@qt.io> Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'tests/benchmarks/corelib/tools/qcryptographichash/CMakeLists.txt')
-rw-r--r--tests/benchmarks/corelib/tools/qcryptographichash/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/tests/benchmarks/corelib/tools/qcryptographichash/CMakeLists.txt b/tests/benchmarks/corelib/tools/qcryptographichash/CMakeLists.txt
index 2ca8e683e1..e9d539eb1a 100644
--- a/tests/benchmarks/corelib/tools/qcryptographichash/CMakeLists.txt
+++ b/tests/benchmarks/corelib/tools/qcryptographichash/CMakeLists.txt
@@ -1,12 +1,10 @@
-# Generated from qcryptographichash.pro.
-
#####################################################################
## tst_bench_qcryptographichash Binary:
#####################################################################
qt_internal_add_benchmark(tst_bench_qcryptographichash
SOURCES
- main.cpp
+ tst_bench_qcryptographichash.cpp
PUBLIC_LIBRARIES
Qt::Test
)