summaryrefslogtreecommitdiffstats
path: root/tests/libfuzzer/gui/painting/qcolorspace/fromiccprofile/CMakeLists.txt
diff options
context:
space:
mode:
authorQt Forward Merge Bot <qt_forward_merge_bot@qt-project.org>2020-04-07 01:00:12 +0200
committerFabian Kosmale <fabian.kosmale@qt.io>2020-04-08 22:04:23 +0200
commitc937ed8af4f3dfef3fd8f8c2a9815376790dd5bf (patch)
tree5175aff87e160ae8f32dadc60d3cfd38b73d4fb1 /tests/libfuzzer/gui/painting/qcolorspace/fromiccprofile/CMakeLists.txt
parente0346df1b21cb30b54ae8d4918addc9925fa8479 (diff)
parent8823bb8d306d78dd6a2e121a708dc607beff58c8 (diff)
Merge "Merge remote-tracking branch 'origin/5.15' into dev"
Diffstat (limited to 'tests/libfuzzer/gui/painting/qcolorspace/fromiccprofile/CMakeLists.txt')
-rw-r--r--tests/libfuzzer/gui/painting/qcolorspace/fromiccprofile/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/tests/libfuzzer/gui/painting/qcolorspace/fromiccprofile/CMakeLists.txt b/tests/libfuzzer/gui/painting/qcolorspace/fromiccprofile/CMakeLists.txt
new file mode 100644
index 0000000000..ec52626e2d
--- /dev/null
+++ b/tests/libfuzzer/gui/painting/qcolorspace/fromiccprofile/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from fromiccprofile.pro.
+
+#####################################################################
+## fromiccprofile Binary:
+#####################################################################
+
+qt_add_executable(fromiccprofile
+ GUI
+ SOURCES
+ main.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+)
+
+#### Keys ignored in scope 1:.:.:fromiccprofile.pro:<TRUE>:
+# FUZZ_ENGINE = "$$(LIB_FUZZING_ENGINE)"
+# QTPLUGIN = "qminimal"
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(fromiccprofile CONDITION FUZZ_ENGINE_ISEMPTY
+ LINK_OPTIONS
+ "-fsanitize=fuzzer"
+)
+
+qt_extend_target(fromiccprofile CONDITION NOT FUZZ_ENGINE_ISEMPTY
+ PUBLIC_LIBRARIES
+ $ENV{LIB_FUZZING_ENGINE}
+)