summaryrefslogtreecommitdiffstats
path: root/tests/manual/CMakeLists.txt
diff options
context:
space:
mode:
authorMårten Nordheim <marten.nordheim@qt.io>2020-12-18 15:35:49 +0100
committerMårten Nordheim <marten.nordheim@qt.io>2021-02-02 11:10:06 +0100
commita3b58a7844f77bd416fad8307f8333ff7c0efacf (patch)
tree83cd728441d5404a0088d07aae8f8b719feadeae /tests/manual/CMakeLists.txt
parent1e3b0d92807323d9138478a66182dff4eaa86b20 (diff)
NetworkListManager based backend for QNetworkInformation
For Windows. Based on the code I wrote for QNetworkStatusMonitor. It also renames the netlistmgr feature, avoiding the abbreviation. Locally my MinGW fails the networklistmanager feature test so it may not be supported on MinGW, likely leaving it without a backend at all. Change-Id: I13bbe4127edc2a9c0bb91602c95f1cb206a85a69 Reviewed-by: Timur Pocheptsov <timur.pocheptsov@qt.io>
Diffstat (limited to 'tests/manual/CMakeLists.txt')
-rw-r--r--tests/manual/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/manual/CMakeLists.txt b/tests/manual/CMakeLists.txt
index 9f48f2832a..f9eb23cd5f 100644
--- a/tests/manual/CMakeLists.txt
+++ b/tests/manual/CMakeLists.txt
@@ -31,6 +31,7 @@ add_subdirectory(qlocale)
add_subdirectory(qmimedatabase)
add_subdirectory(qnetconmonitor)
add_subdirectory(qnetworkaccessmanager/qget)
+add_subdirectory(qnetworkinformation)
#special case begin
if (QT_FEATURE_openssl AND UNIX)
add_subdirectory(qnetworkreply)