summaryrefslogtreecommitdiffstats
path: root/tests/manual/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2012-01-10 06:08:09 +0100
committerQt by Nokia <qt-info@nokia.com>2012-01-12 00:45:40 +0100
commite22431d719518368eb87d842379e4221d578f060 (patch)
tree23ed62b3e994f44de546f12da632b4b0cbf67aad /tests/manual/cmake/CMakeLists.txt
parentb409a81da5d0d14b3ac96497f60c1b599bac60a7 (diff)
Test that the CMAKE_AUTOMOC feature works with Qt5.
Update the wrapper macro which had bitrotted a bit. Change-Id: I65c7940f9ebc0e1c963fddd2bbfc06b89e66df04 Reviewed-by: Alexander Neundorf <neundorf@kde.org> Reviewed-by: Stephen Kelly <stephen.kelly@kdab.com>
Diffstat (limited to 'tests/manual/cmake/CMakeLists.txt')
-rw-r--r--tests/manual/cmake/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/manual/cmake/CMakeLists.txt b/tests/manual/cmake/CMakeLists.txt
index 1f2bd3e80a..91ead649ec 100644
--- a/tests/manual/cmake/CMakeLists.txt
+++ b/tests/manual/cmake/CMakeLists.txt
@@ -25,8 +25,10 @@ macro(expect_fail _dir)
endif()
endmacro()
-# Requires a patched cmake for the automoc stuff. Will uncomment when it is released.
-# expect_pass(pass1)
+if(${CMAKE_VERSION} VERSION_GREATER 2.8.7)
+ # Requires CMAKE_AUTOMOC function in CMake 2.8.7
+ expect_pass(pass1)
+endif()
expect_pass(pass2)
expect_pass(pass3)
expect_fail(fail4)