summaryrefslogtreecommitdiffstats
path: root/tests/manual/examples/widgets/painting/fontsampler/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2023-06-26 14:21:55 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2023-06-28 09:56:39 +0200
commit917282ea53626e4be45c6bb19682776b250948ba (patch)
treea514472d722dc66d715d4dfa7368a15884c09dca /tests/manual/examples/widgets/painting/fontsampler/CMakeLists.txt
parent0b6f5ae131af140088fbc5e770779f9cf8fdbd7f (diff)
Move font sampler example to manual test
Pick-to: 6.5 6.6 Change-Id: I696d9be26edfaadd40579884930b2f061d308a06 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'tests/manual/examples/widgets/painting/fontsampler/CMakeLists.txt')
-rw-r--r--tests/manual/examples/widgets/painting/fontsampler/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/tests/manual/examples/widgets/painting/fontsampler/CMakeLists.txt b/tests/manual/examples/widgets/painting/fontsampler/CMakeLists.txt
new file mode 100644
index 0000000000..faaf510c0f
--- /dev/null
+++ b/tests/manual/examples/widgets/painting/fontsampler/CMakeLists.txt
@@ -0,0 +1,45 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+project(fontsampler LANGUAGES CXX)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/painting/fontsampler")
+
+find_package(Qt6
+ REQUIRED COMPONENTS Core Gui Widgets
+ OPTIONAL_COMPONENTS PrintSupport
+)
+
+qt_standard_project_setup()
+
+qt_add_executable(fontsampler
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ mainwindowbase.ui
+)
+
+set_target_properties(fontsampler PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
+target_link_libraries(fontsampler PRIVATE
+ Qt6::Core
+ Qt6::Gui
+ Qt6::Widgets
+)
+
+if(TARGET Qt6::PrintSupport)
+ target_link_libraries(fontsampler PRIVATE Qt6::PrintSupport)
+endif()
+
+install(TARGETS fontsampler
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)