summaryrefslogtreecommitdiffstats
path: root/tests/manual/foreignwindows/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-07-07 16:56:37 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-07-08 11:01:38 +0200
commit1339cc46678f475f788c9e86618c3824dd86a7ea (patch)
treec339140546e725a4b0d4cc9a7ab92e597ebcff40 /tests/manual/foreignwindows/CMakeLists.txt
parentadbadc57df9f70ee4144f0dd2425192593656394 (diff)
CMake: Regenerate manual tests
Change-Id: Id42b9e481375d2ec0e68b73dc1e2ff36f0cbd49e Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'tests/manual/foreignwindows/CMakeLists.txt')
-rw-r--r--tests/manual/foreignwindows/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/tests/manual/foreignwindows/CMakeLists.txt b/tests/manual/foreignwindows/CMakeLists.txt
index d22636925a..bd0af73058 100644
--- a/tests/manual/foreignwindows/CMakeLists.txt
+++ b/tests/manual/foreignwindows/CMakeLists.txt
@@ -4,7 +4,7 @@
## foreignwindows Binary:
#####################################################################
-add_qt_manual_test(foreignwindows
+qt_add_manual_test(foreignwindows
SOURCES
../diaglib/eventfilter.cpp ../diaglib/eventfilter.h
../diaglib/nativewindowdump.h
@@ -29,19 +29,19 @@ add_qt_manual_test(foreignwindows
## Scopes:
#####################################################################
-extend_target(foreignwindows CONDITION WIN32
+qt_extend_target(foreignwindows CONDITION WIN32
SOURCES
../diaglib/nativewindowdump_win.cpp
PUBLIC_LIBRARIES
user32
)
-extend_target(foreignwindows CONDITION UNIX
+qt_extend_target(foreignwindows CONDITION UNIX
SOURCES
../diaglib/nativewindowdump.cpp
)
-extend_target(foreignwindows CONDITION QT_FEATURE_widgets
+qt_extend_target(foreignwindows CONDITION QT_FEATURE_widgets
SOURCES
../diaglib/debugproxystyle.cpp ../diaglib/debugproxystyle.h
../diaglib/logwidget.cpp ../diaglib/logwidget.h
@@ -50,7 +50,7 @@ extend_target(foreignwindows CONDITION QT_FEATURE_widgets
Qt::WidgetsPrivate
)
-extend_target(foreignwindows CONDITION QT_FEATURE_opengl
+qt_extend_target(foreignwindows CONDITION QT_FEATURE_opengl
SOURCES
../diaglib/glinfo.cpp ../diaglib/glinfo.h
PUBLIC_LIBRARIES