summaryrefslogtreecommitdiffstats
path: root/tests/manual/inputdevices/CMakeLists.txt
diff options
context:
space:
mode:
authorShawn Rutledge <shawn.rutledge@qt.io>2023-03-21 08:15:47 +0100
committerShawn Rutledge <shawn.rutledge@qt.io>2023-03-21 22:00:50 +0100
commitdc7f4f7b4e289a2067c9d8a145a2bfdeba320182 (patch)
treed662318ed19a00186b957dace1da13e50a862cb4 /tests/manual/inputdevices/CMakeLists.txt
parent2a9d93efc68324ce5e41831ea46a3945f1c4531d (diff)
Add a manual test to show a QTreeView with QInputDevice::devices()
At least on X11 this is a real hierarchy: slave devices come and go as children of the master devices. The goal is to verify that this tree and the output of `xinput list` are in sync. The model calls [begin|end]InsertRows() and [begin|end]RemoveRows() as necessary to attempt to keep the view updated. Task-number: QTBUG-46412 Task-number: QTBUG-98720 Task-number: QTBUG-104878 Task-number: QTBUG-112141 Change-Id: I8a2252f041cd1de777eef225d0e7f0db5c90a706 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
Diffstat (limited to 'tests/manual/inputdevices/CMakeLists.txt')
-rw-r--r--tests/manual/inputdevices/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/manual/inputdevices/CMakeLists.txt b/tests/manual/inputdevices/CMakeLists.txt
new file mode 100644
index 0000000000..9440705a9b
--- /dev/null
+++ b/tests/manual/inputdevices/CMakeLists.txt
@@ -0,0 +1,17 @@
+project(inputdevices)
+cmake_minimum_required(VERSION 3.19)
+
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
+
+qt_add_executable(inputdevices
+ main.cpp
+ inputdevicemodel.h inputdevicemodel.cpp
+)
+
+set_target_properties(inputdevices PROPERTIES
+ AUTOMOC TRUE
+)
+
+target_link_libraries(inputdevices PUBLIC
+ Qt::Widgets
+)