summaryrefslogtreecommitdiffstats
path: root/tests/manual/qgraphicslayout/weatheranchorlayout/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Arve Sæther <jan-arve.saether@qt.io>2023-02-28 17:41:48 +0100
committerJan Arve Sæther <jan-arve.saether@qt.io>2023-03-02 05:55:57 +0100
commita84b2e5973ace6327ef38644e023e0f81fad21f4 (patch)
tree3b20a656c6716cf3887906a70145304a9f809d10 /tests/manual/qgraphicslayout/weatheranchorlayout/CMakeLists.txt
parentc6dbae9550e3819a3e1ade1bf06f5d9cb030d561 (diff)
Move Weather Anchor Layout example to manual tests
Pick-to: 6.5 Change-Id: I8782a83b5c12b4f57bf9ef9063818cb124bddd56 Reviewed-by: Oliver Eftevaag <oliver.eftevaag@qt.io>
Diffstat (limited to 'tests/manual/qgraphicslayout/weatheranchorlayout/CMakeLists.txt')
-rw-r--r--tests/manual/qgraphicslayout/weatheranchorlayout/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/manual/qgraphicslayout/weatheranchorlayout/CMakeLists.txt b/tests/manual/qgraphicslayout/weatheranchorlayout/CMakeLists.txt
new file mode 100644
index 0000000000..9f9f3f56f9
--- /dev/null
+++ b/tests/manual/qgraphicslayout/weatheranchorlayout/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## weatheranchorlayout Binary:
+#####################################################################
+cmake_minimum_required(VERSION 3.16)
+
+qt_internal_add_manual_test(weatheranchorlayout
+ GUI
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::Gui
+ Qt::Widgets
+)
+
+# Resources:
+set(weatheranchorlayout_resource_files
+ "images/5days.jpg"
+ "images/details.jpg"
+ "images/place.jpg"
+ "images/tabbar.jpg"
+ "images/title.jpg"
+ "images/weather-few-clouds.png"
+)
+
+qt_add_resources(weatheranchorlayout "weatheranchorlayout"
+ PREFIX
+ "/"
+ FILES
+ ${weatheranchorlayout_resource_files}
+)
+