summaryrefslogtreecommitdiffstats
path: root/tests/manual/rhi/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Fletcher <ben.fletcher@me.com>2022-01-27 12:27:27 -0800
committerBen Fletcher <ben.fletcher@me.com>2022-01-31 08:53:37 -0800
commit9ef702a37bab1916b0aa3bf1403fc27e14113ded (patch)
tree4ca6b85882ec389051e1df16ce4a96800b7c0d75 /tests/manual/rhi/CMakeLists.txt
parent1c3ae79ad36f77a044adb6264396e46575ee8757 (diff)
rhi: Add the basic infrastructure for geometry shader support
.. but this will only be supported on Vulkan, OpenGL 3.2+, and Open GL ES 3.2+ for the time being. The situation is: - Vulkan is working. qsb accepts .geom files already, and QShader has existing geometry shader support. - OpenGL 3.2 and OpenGL ES 3.2 are working. - D3D11 is not working. D3D11 supports geometry shaders, but SPIRV- Cross does not support translating geometry shaders to HLSL. - Metal is not working. Metal does not directly support geometry shaders. Change-Id: Ieb7c44c58b8be5f2e2197bf5133cf6847e6c132d Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
Diffstat (limited to 'tests/manual/rhi/CMakeLists.txt')
-rw-r--r--tests/manual/rhi/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/manual/rhi/CMakeLists.txt b/tests/manual/rhi/CMakeLists.txt
index b3bb4581c3..5441b1e5e8 100644
--- a/tests/manual/rhi/CMakeLists.txt
+++ b/tests/manual/rhi/CMakeLists.txt
@@ -25,3 +25,4 @@ add_subdirectory(tex3d)
add_subdirectory(texturearray)
add_subdirectory(polygonmode)
add_subdirectory(tessellation)
+add_subdirectory(geometryshader)