summaryrefslogtreecommitdiffstats
path: root/tests/manual/rhi/float16texture_with_compute/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-07-07 16:56:37 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-07-08 11:01:38 +0200
commit1339cc46678f475f788c9e86618c3824dd86a7ea (patch)
treec339140546e725a4b0d4cc9a7ab92e597ebcff40 /tests/manual/rhi/float16texture_with_compute/CMakeLists.txt
parentadbadc57df9f70ee4144f0dd2425192593656394 (diff)
CMake: Regenerate manual tests
Change-Id: Id42b9e481375d2ec0e68b73dc1e2ff36f0cbd49e Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'tests/manual/rhi/float16texture_with_compute/CMakeLists.txt')
-rw-r--r--tests/manual/rhi/float16texture_with_compute/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/tests/manual/rhi/float16texture_with_compute/CMakeLists.txt b/tests/manual/rhi/float16texture_with_compute/CMakeLists.txt
new file mode 100644
index 0000000000..935f653742
--- /dev/null
+++ b/tests/manual/rhi/float16texture_with_compute/CMakeLists.txt
@@ -0,0 +1,43 @@
+# Generated from float16texture_with_compute.pro.
+
+#####################################################################
+## float16texture_with_compute Binary:
+#####################################################################
+
+qt_add_manual_test(float16texture_with_compute
+ GUI
+ SOURCES
+ float16texture_with_compute.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::GuiPrivate
+)
+
+# Resources:
+set_source_files_properties("../shared/qt256.png"
+ PROPERTIES QT_RESOURCE_ALIAS "qt256.png"
+)
+set_source_files_properties("../shared/texture.frag.qsb"
+ PROPERTIES QT_RESOURCE_ALIAS "texture.frag.qsb"
+)
+set_source_files_properties("../shared/texture.vert.qsb"
+ PROPERTIES QT_RESOURCE_ALIAS "texture.vert.qsb"
+)
+set(float16texture_with_compute_resource_files
+ "../shared/qt256.png"
+ "../shared/texture.frag.qsb"
+ "../shared/texture.vert.qsb"
+ "load.comp.qsb"
+ "prefilter.comp.qsb"
+)
+
+qt_add_resource(float16texture_with_compute "float16texture_with_compute"
+ PREFIX
+ "/"
+ FILES
+ ${float16texture_with_compute_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:float16texture_with_compute.pro:<TRUE>:
+# TEMPLATE = "app"