summaryrefslogtreecommitdiffstats
path: root/tests/manual/textrendering/codeeditor/CMakeLists.txt
diff options
context:
space:
mode:
authorVolker Hilsheimer <volker.hilsheimer@qt.io>2023-02-08 13:26:22 +0100
committerVolker Hilsheimer <volker.hilsheimer@qt.io>2023-02-09 00:23:34 +0100
commit48a1a5564f89e1e8f0b6f4a28398e4ae0b3f751c (patch)
tree9eb617d59bc9aa66b80fc82eb0aa04cacc166b53 /tests/manual/textrendering/codeeditor/CMakeLists.txt
parent3fe0bf6e1bd3713543a5b763d3bfcee0c03faf4c (diff)
Examples: move widgets/codeeditor into manual tests
It's not a very well written example, using (largely unneed) hacks to implement what it does. It's also misleading - the syntaxhighlighter example is a better showcase for building a useful code editor. Move it to manual tests. Fixes: QTBUG-111025 Pick-to: 6.5 Change-Id: I405d41688235bf3e9a08373e716769f26d02fec6 Reviewed-by: Eskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>
Diffstat (limited to 'tests/manual/textrendering/codeeditor/CMakeLists.txt')
-rw-r--r--tests/manual/textrendering/codeeditor/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/tests/manual/textrendering/codeeditor/CMakeLists.txt b/tests/manual/textrendering/codeeditor/CMakeLists.txt
new file mode 100644
index 0000000000..0e8a3b49ff
--- /dev/null
+++ b/tests/manual/textrendering/codeeditor/CMakeLists.txt
@@ -0,0 +1,37 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+project(codeeditor LANGUAGES CXX)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/widgets/codeeditor")
+
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
+
+qt_standard_project_setup()
+
+qt_add_executable(codeeditor
+ codeeditor.cpp codeeditor.h
+ main.cpp
+)
+
+set_target_properties(codeeditor PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
+target_link_libraries(codeeditor PRIVATE
+ Qt6::Core
+ Qt6::Gui
+ Qt6::Widgets
+)
+
+install(TARGETS codeeditor
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)