summaryrefslogtreecommitdiffstats
path: root/tests/manual/wasm/CMakeLists.txt
diff options
context:
space:
mode:
authorLorn Potter <lorn.potter@gmail.com>2021-05-14 18:37:12 +1000
committerLorn Potter <lorn.potter@gmail.com>2021-12-08 13:39:58 +1000
commitf0be152896471aa392bb1b2b649b66feb31480cc (patch)
treeaa8a3d1c6776416c45578d75177c8eba05ee0f35 /tests/manual/wasm/CMakeLists.txt
parent3b24713098abd34cf8652da815f4dcf3a22110d3 (diff)
wasm: improve clipboard support
Add support for Clipboard API Add clipboard manual test Also includes these fixes: - improve clipboard use for chrome browser - make QClipboard::setText work - html copy and paste - image copy/paste Chrome browser supports text, html and png To use the Clipboard API, apps need to be served from a secure context (https). There is a fallback in the case of non secure context (http) - Firefox requires dom.events.asyncClipboard.read, dom.events.asyncClipboard.clipboardItem and dom.events.asyncClipboard.dataTransfer to be set from about:config, in order to support the Clipboard API. Change-Id: Ie4cb1bbb1dfc77e9655090a30967632780d15dd9 Fixes: QTBUG-74504 Fixes: QTBUG-93619 Fixes: QTBUG-79365 Fixes: QTBUG-86169 Reviewed-by: Morten Johan Sørvig <morten.sorvig@qt.io>
Diffstat (limited to 'tests/manual/wasm/CMakeLists.txt')
-rw-r--r--tests/manual/wasm/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/manual/wasm/CMakeLists.txt b/tests/manual/wasm/CMakeLists.txt
index cd594e7112..dd0d816a5d 100644
--- a/tests/manual/wasm/CMakeLists.txt
+++ b/tests/manual/wasm/CMakeLists.txt
@@ -2,4 +2,5 @@ add_subdirectory(eventloop)
if(QT_FEATURE_widgets)
add_subdirectory(cursors)
add_subdirectory(localfiles)
+add_subdirectory(clipboard)
endif()