summaryrefslogtreecommitdiffstats
path: root/tests/manual/wasm/eventloop/eventloop_auto/CMakeLists.txt
diff options
context:
space:
mode:
authorMorten Sørvig <morten.sorvig@qt.io>2022-07-06 23:01:59 +0200
committerMorten Sørvig <morten.sorvig@qt.io>2022-08-08 18:14:28 +0200
commit964765f686bca3ba62833e76e5ed689fce9a62bb (patch)
treefc0b7cfae17f7a930c07003562115c78548255bc /tests/manual/wasm/eventloop/eventloop_auto/CMakeLists.txt
parent2a17034ddc513870bda49e5d76cb0b1bf358c754 (diff)
wasm: add event loop auto test
Add basic tests for timers and event processing, for different use cases such as on the main thread, on a secondary thread, and with asyncify. Pick-to: 6.4 Change-Id: Ie0f82b5de97f639867b1e65dbb0ab8b11db86f85 Reviewed-by: Lorn Potter <lorn.potter@gmail.com>
Diffstat (limited to 'tests/manual/wasm/eventloop/eventloop_auto/CMakeLists.txt')
-rw-r--r--tests/manual/wasm/eventloop/eventloop_auto/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/manual/wasm/eventloop/eventloop_auto/CMakeLists.txt b/tests/manual/wasm/eventloop/eventloop_auto/CMakeLists.txt
new file mode 100644
index 0000000000..4212cb832b
--- /dev/null
+++ b/tests/manual/wasm/eventloop/eventloop_auto/CMakeLists.txt
@@ -0,0 +1,21 @@
+qt_internal_add_manual_test(eventloop_auto
+ SOURCES
+ main.cpp
+ ../../qtwasmtestlib/qtwasmtestlib.cpp
+ PUBLIC_LIBRARIES
+ Qt::Core
+)
+
+include_directories(../../qtwasmtestlib/)
+
+add_custom_command(
+ TARGET eventloop_auto POST_BUILD
+ COMMAND ${CMAKE_COMMAND} -E copy
+ ${CMAKE_CURRENT_SOURCE_DIR}/eventloop_auto.html
+ ${CMAKE_CURRENT_BINARY_DIR}/eventloop_auto.html)
+
+add_custom_command(
+ TARGET eventloop_auto POST_BUILD
+ COMMAND ${CMAKE_COMMAND} -E copy
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../qtwasmtestlib/qtwasmtestlib.js
+ ${CMAKE_CURRENT_BINARY_DIR}/qtwasmtestlib.js)