summaryrefslogtreecommitdiffstats
path: root/tests/manual/wasm/eventloop/main_exec/CMakeLists.txt
diff options
context:
space:
mode:
authorMorten Johan Sørvig <morten.sorvig@qt.io>2021-08-12 18:40:08 +0200
committerMorten Johan Sørvig <morten.sorvig@qt.io>2021-08-27 15:45:24 +0200
commit82f14a95b5d2b41a47bc1ba65c2c9b880dd4accb (patch)
treed5bac4f6786fc363f24bb4e8914a17dd31ec7d3e /tests/manual/wasm/eventloop/main_exec/CMakeLists.txt
parentc6362cd55c53b7990fce5ca6dc532f6d855ea690 (diff)
wasm: add manual tests for main() and exec()
Add minimal examples which demonstrates how exec() works on Qt for WebAssembly and how to implement main() without calling QApplication::exec(). Change-Id: I44f1d16af19c538380cc56faf3f0f4cc9d66cf11 Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
Diffstat (limited to 'tests/manual/wasm/eventloop/main_exec/CMakeLists.txt')
-rw-r--r--tests/manual/wasm/eventloop/main_exec/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/manual/wasm/eventloop/main_exec/CMakeLists.txt b/tests/manual/wasm/eventloop/main_exec/CMakeLists.txt
new file mode 100644
index 0000000000..b5d987f8cb
--- /dev/null
+++ b/tests/manual/wasm/eventloop/main_exec/CMakeLists.txt
@@ -0,0 +1,8 @@
+qt_internal_add_manual_test(main_exec
+ GUI
+ SOURCES
+ main.cpp
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+)