summaryrefslogtreecommitdiffstats
path: root/tests/manual/widgets/kernel/setscreen/CMakeLists.txt
diff options
context:
space:
mode:
authorVolker Hilsheimer <volker.hilsheimer@qt.io>2020-08-12 13:21:42 +0200
committerVolker Hilsheimer <volker.hilsheimer@qt.io>2020-08-17 15:08:39 +0200
commitc54a5b83804c00474d141b485b752a7c54169ebf (patch)
tree9016e1579b219072547a4d6892f500929e01e3c8 /tests/manual/widgets/kernel/setscreen/CMakeLists.txt
parentc4366ff0183a9a4a5c6eff0312b713e9c5eb97ea (diff)
Introduce QWidget::setScreen
Follows the QWindow semantics, and is a replacement for creating a QWidget with a QDesktopScreenWidget as the parent. We can now remove much of the special handling of QDesktopWidget and the Qt::Desktop window type, and get rid of QDesktopScreenWidget. Add a manual test that allows local testing. Our CI environments only have a single screen, and no multi-head display server setup which is the primary case where QWidget::setScreen is interesting. For the more common case of a virtual desktop, QWidget::setScreen has no real impact (just as QWindow::setScreen doesn't). Change-Id: Id0099e069d316741bacd8c795c396ccad37be297 Fixes: QTBUG-85483 Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
Diffstat (limited to 'tests/manual/widgets/kernel/setscreen/CMakeLists.txt')
-rw-r--r--tests/manual/widgets/kernel/setscreen/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/manual/widgets/kernel/setscreen/CMakeLists.txt b/tests/manual/widgets/kernel/setscreen/CMakeLists.txt
new file mode 100644
index 0000000000..cf31341d7c
--- /dev/null
+++ b/tests/manual/widgets/kernel/setscreen/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Generated from setscreen.pro.
+
+#####################################################################
+## setscreen Binary:
+#####################################################################
+
+qt_add_manual_test(setscreen
+ GUI
+ SOURCES
+ main.cpp
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::Widgets
+)
+
+#### Keys ignored in scope 1:.:.:setscreen.pro:<TRUE>:
+# TEMPLATE = "app"