summaryrefslogtreecommitdiffstats
path: root/config.tests/separate_debug_info/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'config.tests/separate_debug_info/CMakeLists.txt')
-rw-r--r--config.tests/separate_debug_info/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/config.tests/separate_debug_info/CMakeLists.txt b/config.tests/separate_debug_info/CMakeLists.txt
new file mode 100644
index 0000000000..757374a34a
--- /dev/null
+++ b/config.tests/separate_debug_info/CMakeLists.txt
@@ -0,0 +1,10 @@
+cmake_minimum_required(VERSION 3.14.0)
+project(objcopytest LANGUAGES CXX)
+include(CMakeFindBinUtils)
+add_executable(objcopytest main.cpp)
+add_custom_command(
+ TARGET objcopytest
+ POST_BUILD
+ COMMAND ${CMAKE_OBJCOPY} --only-keep-debug $<TARGET_FILE:objcopytest> objcopytest.debug
+ COMMAND ${CMAKE_OBJCOPY} --strip-debug $<TARGET_FILE:objcopytest>
+ COMMAND ${CMAKE_OBJCOPY} --add-gnu-debuglink=objcopytest.debug $<TARGET_FILE:objcopytest>)