summaryrefslogtreecommitdiffstats
path: root/config.tests/static_link_order/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'config.tests/static_link_order/CMakeLists.txt')
-rw-r--r--config.tests/static_link_order/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/config.tests/static_link_order/CMakeLists.txt b/config.tests/static_link_order/CMakeLists.txt
index 36ce10e87c..c174fb95db 100644
--- a/config.tests/static_link_order/CMakeLists.txt
+++ b/config.tests/static_link_order/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# The test represents the order-related issue that we have with the ld linker.
#
# CMake versions < 3.21.0 produce the following linker line:
@@ -7,7 +10,7 @@
# staticlib2.cpp.o.
#
# For now it's only applicable for ld-like linkers. 'lld' has no such issue.
-cmake_minimum_required(VERSION 3.14)
+cmake_minimum_required(VERSION 3.16)
project(static_link_order_test LANGUAGES CXX)