summaryrefslogtreecommitdiffstats
path: root/examples/corelib/ipc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/corelib/ipc/CMakeLists.txt')
-rw-r--r--examples/corelib/ipc/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/examples/corelib/ipc/CMakeLists.txt b/examples/corelib/ipc/CMakeLists.txt
index d1cfc7bc1b..270f71faec 100644
--- a/examples/corelib/ipc/CMakeLists.txt
+++ b/examples/corelib/ipc/CMakeLists.txt
@@ -1,10 +1,10 @@
# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
if(NOT TARGET Qt6::Widgets)
return()
endif()
-if(QT_FEATURE_sharedmemory)
+if(QT_FEATURE_sharedmemory AND QT_FEATURE_systemsemaphore)
qt_internal_add_example(sharedmemory)
endif()
if(QT_FEATURE_localserver AND TARGET Qt6::Network)