summaryrefslogtreecommitdiffstats
path: root/examples/corelib/threads/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/corelib/threads/CMakeLists.txt')
-rw-r--r--examples/corelib/threads/CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/examples/corelib/threads/CMakeLists.txt b/examples/corelib/threads/CMakeLists.txt
index 848880d076..670821a77d 100644
--- a/examples/corelib/threads/CMakeLists.txt
+++ b/examples/corelib/threads/CMakeLists.txt
@@ -1,8 +1,11 @@
-# Generated from threads.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-qt_internal_add_example(semaphores)
-qt_internal_add_example(waitconditions)
-if(TARGET Qt::Widgets)
+if(NOT ANDROID)
+ qt_internal_add_example(semaphores)
+ qt_internal_add_example(waitconditions)
+endif()
+if(TARGET Qt6::Widgets)
qt_internal_add_example(mandelbrot)
qt_internal_add_example(queuedcustomtype)
endif()