summaryrefslogtreecommitdiffstats
path: root/examples/dbus/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dbus/CMakeLists.txt')
-rw-r--r--examples/dbus/CMakeLists.txt23
1 files changed, 13 insertions, 10 deletions
diff --git a/examples/dbus/CMakeLists.txt b/examples/dbus/CMakeLists.txt
index 42a3df658a..79caaf949d 100644
--- a/examples/dbus/CMakeLists.txt
+++ b/examples/dbus/CMakeLists.txt
@@ -1,13 +1,16 @@
-# Generated from dbus.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-add_subdirectory(listnames)
-add_subdirectory(pingpong)
-
-if(QT_FEATURE_process)
- add_subdirectory(complexpingpong)
+if(NOT TARGET Qt6::DBus)
+ return()
endif()
-
-if(TARGET Qt::Widgets)
- add_subdirectory(chat)
- add_subdirectory(remotecontrolledcar)
+if(NOT ANDROID)
+ qt_internal_add_example(pingpong)
+ if(QT_FEATURE_process)
+ qt_internal_add_example(complexpingpong)
+ endif()
+endif()
+if(TARGET Qt6::Widgets)
+ qt_internal_add_example(chat)
+ qt_internal_add_example(remotecontrolledcar)
endif()