summaryrefslogtreecommitdiffstats
path: root/examples/dbus/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dbus/CMakeLists.txt')
-rw-r--r--examples/dbus/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/examples/dbus/CMakeLists.txt b/examples/dbus/CMakeLists.txt
index 738d1e47f7..79caaf949d 100644
--- a/examples/dbus/CMakeLists.txt
+++ b/examples/dbus/CMakeLists.txt
@@ -1,12 +1,14 @@
# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
if(NOT TARGET Qt6::DBus)
return()
endif()
-qt_internal_add_example(pingpong)
-if(QT_FEATURE_process)
- qt_internal_add_example(complexpingpong)
+if(NOT ANDROID)
+ qt_internal_add_example(pingpong)
+ if(QT_FEATURE_process)
+ qt_internal_add_example(complexpingpong)
+ endif()
endif()
if(TARGET Qt6::Widgets)
qt_internal_add_example(chat)