summaryrefslogtreecommitdiffstats
path: root/examples/dbus/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dbus/CMakeLists.txt')
-rw-r--r--examples/dbus/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/dbus/CMakeLists.txt b/examples/dbus/CMakeLists.txt
index 42a3df658a..065cc76022 100644
--- a/examples/dbus/CMakeLists.txt
+++ b/examples/dbus/CMakeLists.txt
@@ -1,12 +1,13 @@
# Generated from dbus.pro.
+if(NOT TARGET Qt::DBus)
+ return()
+endif()
add_subdirectory(listnames)
add_subdirectory(pingpong)
-
if(QT_FEATURE_process)
add_subdirectory(complexpingpong)
endif()
-
if(TARGET Qt::Widgets)
add_subdirectory(chat)
add_subdirectory(remotecontrolledcar)