summaryrefslogtreecommitdiffstats
path: root/examples/dbus/listnames/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dbus/listnames/CMakeLists.txt')
-rw-r--r--examples/dbus/listnames/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/examples/dbus/listnames/CMakeLists.txt b/examples/dbus/listnames/CMakeLists.txt
index 3b92cafa96..dec2622ebd 100644
--- a/examples/dbus/listnames/CMakeLists.txt
+++ b/examples/dbus/listnames/CMakeLists.txt
@@ -4,8 +4,6 @@
cmake_minimum_required(VERSION 3.16)
project(listnames LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()
@@ -14,6 +12,8 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/dbus/listnames")
find_package(Qt6 REQUIRED COMPONENTS Core DBus)
+qt_standard_project_setup()
+
qt_add_executable(listnames
listnames.cpp
)