summaryrefslogtreecommitdiffstats
path: root/examples/dbus/pingpong/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dbus/pingpong/CMakeLists.txt')
-rw-r--r--examples/dbus/pingpong/CMakeLists.txt50
1 files changed, 10 insertions, 40 deletions
diff --git a/examples/dbus/pingpong/CMakeLists.txt b/examples/dbus/pingpong/CMakeLists.txt
index 24cfe887ff..b8ba8231d1 100644
--- a/examples/dbus/pingpong/CMakeLists.txt
+++ b/examples/dbus/pingpong/CMakeLists.txt
@@ -1,7 +1,5 @@
-# Generated from pingpong.pro.
-
cmake_minimum_required(VERSION 3.16)
-project(ping LANGUAGES CXX)
+project(pingpong LANGUAGES CXX)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
@@ -10,62 +8,34 @@ set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/dbus/pingpong")
-find_package(Qt6 COMPONENTS DBus)
+find_package(Qt6 COMPONENTS Core DBus)
qt_add_executable(ping
ping.cpp
ping-common.h
)
-set_target_properties(ping PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-target_link_libraries(ping PUBLIC
- # Remove: gui
- Qt::DBus
-)
-install(TARGETS ping
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+target_link_libraries(ping PUBLIC
+ Qt6::Core
+ Qt6::DBus
)
-cmake_minimum_required(VERSION 3.16)
-project(pong LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/dbus/pingpong")
-
-find_package(Qt6 COMPONENTS DBus)
qt_add_executable(pong
ping-common.h
pong.cpp pong.h
)
-set_target_properties(pong PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
+
target_link_libraries(pong PUBLIC
- # Remove: gui
- Qt::DBus
+ Qt6::Core
+ Qt6::DBus
)
-install(TARGETS pong
+install(TARGETS ping pong
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"