summaryrefslogtreecommitdiffstats
path: root/examples/dbus/remotecontrolledcar/controller/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dbus/remotecontrolledcar/controller/CMakeLists.txt')
-rw-r--r--examples/dbus/remotecontrolledcar/controller/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/examples/dbus/remotecontrolledcar/controller/CMakeLists.txt b/examples/dbus/remotecontrolledcar/controller/CMakeLists.txt
new file mode 100644
index 0000000000..a0c1aea7c5
--- /dev/null
+++ b/examples/dbus/remotecontrolledcar/controller/CMakeLists.txt
@@ -0,0 +1,53 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(controller_SRCS)
+qt_add_dbus_interface(controller_SRCS
+ ../common/car.xml
+ car_interface
+)
+
+qt_add_executable(controller
+ controller.cpp controller.h
+ main.cpp
+ ${controller_SRCS}
+)
+
+qt_add_resources(controller
+ PREFIX
+ "/"
+ FILES
+ down.svg
+ left.svg
+ right.svg
+ up.svg
+ connected.svg
+ connecting.svg
+)
+
+set_target_properties(controller PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
+target_link_libraries(controller PRIVATE
+ Qt6::Core
+ Qt6::DBus
+ Qt6::Gui
+ Qt6::Widgets
+)
+
+install(TARGETS controller
+ BUNDLE DESTINATION .
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+)
+
+qt_generate_deploy_app_script(
+ TARGET controller
+ OUTPUT_SCRIPT deploy_script
+ NO_UNSUPPORTED_PLATFORM_ERROR
+)
+install(SCRIPT ${deploy_script})