summaryrefslogtreecommitdiffstats
path: root/examples/gui/analogclock/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/gui/analogclock/CMakeLists.txt')
-rw-r--r--examples/gui/analogclock/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/examples/gui/analogclock/CMakeLists.txt b/examples/gui/analogclock/CMakeLists.txt
index 20bedf5a37..4c694e425e 100644
--- a/examples/gui/analogclock/CMakeLists.txt
+++ b/examples/gui/analogclock/CMakeLists.txt
@@ -16,9 +16,7 @@ endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/gui/gui_analogclock") # special case
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets) # special case: add
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
qt_add_executable(gui_analogclock # special case: renamed target
../rasterwindow/rasterwindow.cpp ../rasterwindow/rasterwindow.h