summaryrefslogtreecommitdiffstats
path: root/examples/gui/rhiwindow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/gui/rhiwindow/CMakeLists.txt')
-rw-r--r--examples/gui/rhiwindow/CMakeLists.txt21
1 files changed, 11 insertions, 10 deletions
diff --git a/examples/gui/rhiwindow/CMakeLists.txt b/examples/gui/rhiwindow/CMakeLists.txt
index 3c50add134..49b36286ee 100644
--- a/examples/gui/rhiwindow/CMakeLists.txt
+++ b/examples/gui/rhiwindow/CMakeLists.txt
@@ -1,15 +1,9 @@
# Copyright (C) 2023 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
cmake_minimum_required(VERSION 3.16)
project(rhiwindow LANGUAGES CXX)
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/gui/rhiwindow")
-
find_package(Qt6 REQUIRED COMPONENTS Core Gui)
qt_standard_project_setup()
@@ -53,7 +47,14 @@ qt_add_resources(rhiwindow "rhiwindow"
)
install(TARGETS rhiwindow
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION .
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+)
+
+qt_generate_deploy_app_script(
+ TARGET rhiwindow
+ OUTPUT_SCRIPT deploy_script
+ NO_UNSUPPORTED_PLATFORM_ERROR
)
+install(SCRIPT ${deploy_script})