summaryrefslogtreecommitdiffstats
path: root/examples/network/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/network/CMakeLists.txt')
-rw-r--r--examples/network/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/examples/network/CMakeLists.txt b/examples/network/CMakeLists.txt
new file mode 100644
index 0000000000..6222bb7c8b
--- /dev/null
+++ b/examples/network/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+if(NOT TARGET Qt6::Network)
+ return()
+endif()
+if(NOT INTEGRITY AND NOT ANDROID)
+ qt_internal_add_example(dnslookup)
+endif()
+if(TARGET Qt6::Widgets)
+ qt_internal_add_example(blockingfortuneclient)
+ qt_internal_add_example(broadcastreceiver)
+ qt_internal_add_example(broadcastsender)
+ qt_internal_add_example(http)
+ qt_internal_add_example(threadedfortuneserver)
+ qt_internal_add_example(torrent)
+ qt_internal_add_example(multicastreceiver)
+ qt_internal_add_example(multicastsender)
+ qt_internal_add_example(fortuneclient)
+ qt_internal_add_example(fortuneserver)
+ qt_internal_add_example(rsslisting)
+endif()
+if(QT_FEATURE_processenvironment AND TARGET Qt6::Widgets)
+ qt_internal_add_example(network-chat)
+endif()
+if(QT_FEATURE_ssl AND TARGET Qt6::Widgets)
+ qt_internal_add_example(securesocketclient)
+endif()
+if(QT_FEATURE_dtls AND TARGET Qt6::Widgets)
+ qt_internal_add_example(secureudpserver)
+ qt_internal_add_example(secureudpclient)
+endif()
+if(QT_FEATURE_sctp AND TARGET Qt6::Widgets)
+ qt_internal_add_example(multistreamserver)
+ qt_internal_add_example(multistreamclient)
+endif()