summaryrefslogtreecommitdiffstats
path: root/examples/network/dnslookup/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/network/dnslookup/CMakeLists.txt')
-rw-r--r--examples/network/dnslookup/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/network/dnslookup/CMakeLists.txt b/examples/network/dnslookup/CMakeLists.txt
index e90cdaff2d..39f680f334 100644
--- a/examples/network/dnslookup/CMakeLists.txt
+++ b/examples/network/dnslookup/CMakeLists.txt
@@ -4,6 +4,10 @@
cmake_minimum_required(VERSION 3.16)
project(dnslookup LANGUAGES CXX)
+if (ANDROID)
+ message(FATAL_ERROR "This project cannot be built on Android.")
+endif()
+
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()