summaryrefslogtreecommitdiffstats
path: root/examples/network/dnslookup/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/network/dnslookup/CMakeLists.txt')
-rw-r--r--examples/network/dnslookup/CMakeLists.txt41
1 files changed, 21 insertions, 20 deletions
diff --git a/examples/network/dnslookup/CMakeLists.txt b/examples/network/dnslookup/CMakeLists.txt
index 6ffc633a96..8aa5bea4cb 100644
--- a/examples/network/dnslookup/CMakeLists.txt
+++ b/examples/network/dnslookup/CMakeLists.txt
@@ -1,27 +1,28 @@
# Generated from dnslookup.pro.
-#####################################################################
-## dnslookup Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(dnslookup LANGUAGES CXX)
-add_qt_executable(dnslookup
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/network/dnslookup"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/network/dnslookup"
- SOURCES
- dnslookup.cpp dnslookup.h
- LIBRARIES
- Qt::Network
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
-#### Keys ignored in scope 1:.:dnslookup.pro:<NONE>:
-# TEMPLATE = "app"
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-## Scopes:
-#####################################################################
+set(INSTALL_EXAMPLEDIR "examples")
-#### Keys ignored in scope 2:.:dnslookup.pro:APPLE_OSX:
-# CONFIG = "-app_bundle"
+find_package(Qt5 COMPONENTS Core)
+find_package(Qt5 COMPONENTS Network)
-#### Keys ignored in scope 3:.:dnslookup.pro:WIN32:
-# CONFIG = "console"
+add_executable(dnslookup
+ dnslookup.cpp dnslookup.h
+)
+target_link_libraries(dnslookup PUBLIC
+ Qt::Core
+ Qt::Network
+)
+
+install(TARGETS dnslookup
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)