summaryrefslogtreecommitdiffstats
path: root/examples/network/network-chat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/network/network-chat/CMakeLists.txt')
-rw-r--r--examples/network/network-chat/CMakeLists.txt25
1 files changed, 15 insertions, 10 deletions
diff --git a/examples/network/network-chat/CMakeLists.txt b/examples/network/network-chat/CMakeLists.txt
index 6b6abd1c46..127a4c2fb5 100644
--- a/examples/network/network-chat/CMakeLists.txt
+++ b/examples/network/network-chat/CMakeLists.txt
@@ -1,15 +1,9 @@
# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
cmake_minimum_required(VERSION 3.16)
project(network-chat LANGUAGES CXX)
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/network/network-chat")
-
find_package(Qt6 REQUIRED COMPONENTS Core Gui Network Widgets)
qt_standard_project_setup()
@@ -28,6 +22,10 @@ set_target_properties(network-chat PROPERTIES
MACOSX_BUNDLE TRUE
)
+target_compile_definitions(network-chat PRIVATE
+ QT_USE_QSTRINGBUILDER
+)
+
target_link_libraries(network-chat PRIVATE
Qt6::Core
Qt6::Gui
@@ -36,7 +34,14 @@ target_link_libraries(network-chat PRIVATE
)
install(TARGETS network-chat
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION .
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+)
+
+qt_generate_deploy_app_script(
+ TARGET network-chat
+ OUTPUT_SCRIPT deploy_script
+ NO_UNSUPPORTED_PLATFORM_ERROR
)
+install(SCRIPT ${deploy_script})