summaryrefslogtreecommitdiffstats
path: root/examples/opengl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/opengl/CMakeLists.txt')
-rw-r--r--examples/opengl/CMakeLists.txt25
1 files changed, 10 insertions, 15 deletions
diff --git a/examples/opengl/CMakeLists.txt b/examples/opengl/CMakeLists.txt
index 3d5b055b1a..09e31defe5 100644
--- a/examples/opengl/CMakeLists.txt
+++ b/examples/opengl/CMakeLists.txt
@@ -1,17 +1,12 @@
-# Generated from opengl.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-add_subdirectory(hellowindow)
-add_subdirectory(paintedwindow)
-add_subdirectory(openglwindow)
-add_subdirectory(qopenglwindow)
-if(TARGET Qt::Widgets)
- add_subdirectory(contextinfo)
- add_subdirectory(threadedqopenglwidget)
- add_subdirectory(2dpainting)
- add_subdirectory(hellogl2)
- add_subdirectory(qopenglwidget)
- add_subdirectory(cube)
- add_subdirectory(textures)
- add_subdirectory(hellogles3)
- add_subdirectory(computegles31)
+qt_internal_add_example(openglwindow)
+qt_internal_add_example(hellogles3)
+if(TARGET Qt6::Widgets)
+ qt_internal_add_example(2dpainting)
+ qt_internal_add_example(hellogl2)
+ qt_internal_add_example(cube)
+ qt_internal_add_example(textures)
+ qt_internal_add_example(stereoqopenglwidget)
endif()