summaryrefslogtreecommitdiffstats
path: root/examples/opengl/qopenglwindow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/opengl/qopenglwindow/CMakeLists.txt')
-rw-r--r--examples/opengl/qopenglwindow/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/opengl/qopenglwindow/CMakeLists.txt b/examples/opengl/qopenglwindow/CMakeLists.txt
index 1236df6148..f4b01ebbb7 100644
--- a/examples/opengl/qopenglwindow/CMakeLists.txt
+++ b/examples/opengl/qopenglwindow/CMakeLists.txt
@@ -8,7 +8,7 @@ set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/opengl/qopenglwindow")
@@ -19,10 +19,12 @@ qt_add_executable(qopenglwindow
background_renderer.cpp background_renderer.h
main.cpp
)
+
set_target_properties(qopenglwindow PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_include_directories(qopenglwindow PUBLIC
.
)
@@ -33,7 +35,6 @@ target_link_libraries(qopenglwindow PUBLIC
Qt::OpenGL
)
-
# Resources:
set(shaders_resource_files
"background.frag"