summaryrefslogtreecommitdiffstats
path: root/examples/qtconcurrent/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qtconcurrent/CMakeLists.txt')
-rw-r--r--examples/qtconcurrent/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/examples/qtconcurrent/CMakeLists.txt b/examples/qtconcurrent/CMakeLists.txt
new file mode 100644
index 0000000000..13e78678d8
--- /dev/null
+++ b/examples/qtconcurrent/CMakeLists.txt
@@ -0,0 +1,11 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+if(NOT TARGET Qt6::Concurrent)
+ return()
+endif()
+if(TARGET Qt6::Widgets)
+ qt_internal_add_example(imagescaling)
+ qt_internal_add_example(primecounter)
+ qt_internal_add_example(wordcount)
+endif()