summaryrefslogtreecommitdiffstats
path: root/examples/qtconcurrent/progressdialog/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qtconcurrent/progressdialog/CMakeLists.txt')
-rw-r--r--examples/qtconcurrent/progressdialog/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/examples/qtconcurrent/progressdialog/CMakeLists.txt b/examples/qtconcurrent/progressdialog/CMakeLists.txt
index 1a4f3b1440..3efe2fc6c8 100644
--- a/examples/qtconcurrent/progressdialog/CMakeLists.txt
+++ b/examples/qtconcurrent/progressdialog/CMakeLists.txt
@@ -8,7 +8,7 @@ set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/qtconcurrent/progressdialog")
@@ -18,10 +18,12 @@ find_package(Qt6 REQUIRED COMPONENTS Concurrent Core Gui Widgets)
qt_add_executable(progressdialog
main.cpp
)
+
set_target_properties(progressdialog PROPERTIES
WIN32_EXECUTABLE FALSE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(progressdialog PUBLIC
Qt::Concurrent
Qt::Core