summaryrefslogtreecommitdiffstats
path: root/examples/vulkan/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/vulkan/CMakeLists.txt')
-rw-r--r--examples/vulkan/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/examples/vulkan/CMakeLists.txt b/examples/vulkan/CMakeLists.txt
new file mode 100644
index 0000000000..98b0a31b5e
--- /dev/null
+++ b/examples/vulkan/CMakeLists.txt
@@ -0,0 +1,10 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+qt_internal_add_example(hellovulkantriangle)
+if(TARGET Qt6::Widgets)
+ qt_internal_add_example(hellovulkanwidget)
+endif()
+if(TARGET Qt6::Concurrent AND TARGET Qt6::Widgets)
+ qt_internal_add_example(hellovulkancubes)
+endif()