summaryrefslogtreecommitdiffstats
path: root/examples/vulkan/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/vulkan/CMakeLists.txt')
-rw-r--r--examples/vulkan/CMakeLists.txt15
1 files changed, 7 insertions, 8 deletions
diff --git a/examples/vulkan/CMakeLists.txt b/examples/vulkan/CMakeLists.txt
index b00a40447a..98b0a31b5e 100644
--- a/examples/vulkan/CMakeLists.txt
+++ b/examples/vulkan/CMakeLists.txt
@@ -1,11 +1,10 @@
-# Generated from vulkan.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-add_subdirectory(hellovulkanwindow)
-add_subdirectory(hellovulkantriangle)
-add_subdirectory(hellovulkantexture)
-if(TARGET Qt::Widgets)
- add_subdirectory(hellovulkanwidget)
+qt_internal_add_example(hellovulkantriangle)
+if(TARGET Qt6::Widgets)
+ qt_internal_add_example(hellovulkanwidget)
endif()
-if(TARGET Qt::Concurrent AND TARGET Qt::Widgets)
- add_subdirectory(hellovulkancubes)
+if(TARGET Qt6::Concurrent AND TARGET Qt6::Widgets)
+ qt_internal_add_example(hellovulkancubes)
endif()