summaryrefslogtreecommitdiffstats
path: root/examples/widgets/animation/states/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/animation/states/CMakeLists.txt')
-rw-r--r--examples/widgets/animation/states/CMakeLists.txt42
1 files changed, 22 insertions, 20 deletions
diff --git a/examples/widgets/animation/states/CMakeLists.txt b/examples/widgets/animation/states/CMakeLists.txt
index 52a9357789..a28995db99 100644
--- a/examples/widgets/animation/states/CMakeLists.txt
+++ b/examples/widgets/animation/states/CMakeLists.txt
@@ -1,25 +1,27 @@
# Generated from states.pro.
-#####################################################################
-## states Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(states LANGUAGES CXX)
-add_qt_executable(states
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/animation/states"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/animation/states"
- SOURCES
- main.cpp
- LIBRARIES
- Qt::Widgets
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-# Resources:
-add_qt_resource(states "states" FILES
- accessories-dictionary.png
- akregator.png
- digikam.png
- help-browser.png
- k3b.png
- kchart.png)
+set(INSTALL_EXAMPLEDIR "examples")
+find_package(Qt5 COMPONENTS Widgets)
+
+add_executable(states WIN32 MACOSX_BUNDLE
+ main.cpp
+ states.qrc
+)
+target_link_libraries(states PUBLIC
+ Qt::Widgets
+)
+
+install(TARGETS states
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)