summaryrefslogtreecommitdiffstats
path: root/examples/widgets/animation/stickman/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/animation/stickman/CMakeLists.txt')
-rw-r--r--examples/widgets/animation/stickman/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/examples/widgets/animation/stickman/CMakeLists.txt b/examples/widgets/animation/stickman/CMakeLists.txt
new file mode 100644
index 0000000000..f604598232
--- /dev/null
+++ b/examples/widgets/animation/stickman/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Generated from stickman.pro.
+
+#####################################################################
+## stickman Binary:
+#####################################################################
+
+add_qt_executable(stickman
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/animation/stickman"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/animation/stickman"
+ SOURCES
+ animation.cpp animation.h
+ graphicsview.cpp graphicsview.h
+ lifecycle.cpp lifecycle.h
+ main.cpp
+ node.cpp node.h
+ rectbutton.cpp rectbutton.h
+ stickman.cpp stickman.h
+ LIBRARIES
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(stickman "stickman" FILES
+ animations/chilling.bin
+ animations/dancing.bin
+ animations/dead.bin
+ animations/jumping.bin)
+