summaryrefslogtreecommitdiffstats
path: root/examples/widgets/graphicsview/boxes/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/graphicsview/boxes/CMakeLists.txt')
-rw-r--r--examples/widgets/graphicsview/boxes/CMakeLists.txt39
1 files changed, 0 insertions, 39 deletions
diff --git a/examples/widgets/graphicsview/boxes/CMakeLists.txt b/examples/widgets/graphicsview/boxes/CMakeLists.txt
deleted file mode 100644
index 0be040f90e..0000000000
--- a/examples/widgets/graphicsview/boxes/CMakeLists.txt
+++ /dev/null
@@ -1,39 +0,0 @@
-# Generated from boxes.pro.
-
-cmake_minimum_required(VERSION 3.14)
-project(boxes LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-set(INSTALL_EXAMPLEDIR "examples")
-
-find_package(Qt6 COMPONENTS OpenGL)
-find_package(Qt6 COMPONENTS Widgets)
-
-
-add_qt_gui_executable(boxes
- 3rdparty/fbm.c 3rdparty/fbm.h
- boxes.qrc
- glbuffers.cpp glbuffers.h
- glextensions.cpp glextensions.h
- gltrianglemesh.h
- main.cpp
- qtbox.cpp qtbox.h
- roundedbox.cpp roundedbox.h
- scene.cpp scene.h
- trackball.cpp trackball.h
-)
-target_link_libraries(boxes PUBLIC
- Qt::OpenGL
- Qt::Widgets
-)
-
-install(TARGETS boxes
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)