summaryrefslogtreecommitdiffstats
path: root/examples/widgets/layouts/dynamiclayouts/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/layouts/dynamiclayouts/CMakeLists.txt')
-rw-r--r--examples/widgets/layouts/dynamiclayouts/CMakeLists.txt35
1 files changed, 23 insertions, 12 deletions
diff --git a/examples/widgets/layouts/dynamiclayouts/CMakeLists.txt b/examples/widgets/layouts/dynamiclayouts/CMakeLists.txt
index 47f935bf68..1989672b9c 100644
--- a/examples/widgets/layouts/dynamiclayouts/CMakeLists.txt
+++ b/examples/widgets/layouts/dynamiclayouts/CMakeLists.txt
@@ -1,16 +1,27 @@
# Generated from dynamiclayouts.pro.
-#####################################################################
-## dynamiclayouts Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(dynamiclayouts LANGUAGES CXX)
-add_qt_executable(dynamiclayouts
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/layouts/dynamiclayouts"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/layouts/dynamiclayouts"
- SOURCES
- dialog.cpp dialog.h
- main.cpp
- LIBRARIES
- Qt::Widgets
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt5 COMPONENTS Widgets)
+
+add_executable(dynamiclayouts WIN32 MACOSX_BUNDLE
+ dialog.cpp dialog.h
+ main.cpp
+)
+target_link_libraries(dynamiclayouts PUBLIC
+ Qt::Widgets
+)
+
+install(TARGETS dynamiclayouts
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
)