summaryrefslogtreecommitdiffstats
path: root/examples/widgets/painting/affine/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/painting/affine/CMakeLists.txt')
-rw-r--r--examples/widgets/painting/affine/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/examples/widgets/painting/affine/CMakeLists.txt b/examples/widgets/painting/affine/CMakeLists.txt
index 4c9b0f6ac0..93cbcc416f 100644
--- a/examples/widgets/painting/affine/CMakeLists.txt
+++ b/examples/widgets/painting/affine/CMakeLists.txt
@@ -28,7 +28,7 @@ set_target_properties(affine PROPERTIES
MACOSX_BUNDLE TRUE
)
-target_include_directories(affine PUBLIC
+target_include_directories(affine PRIVATE
../shared
)
@@ -36,7 +36,7 @@ if(NOT TARGET painting_shared::painting_shared)
include(../shared/use_lib.cmake)
endif()
-target_link_libraries(affine PUBLIC
+target_link_libraries(affine PRIVATE
Qt6::Core
Qt6::Gui
Qt6::Widgets
@@ -106,11 +106,11 @@ qt_add_resources(affine "affine"
# remove files from ../shared
#if(QT_FEATURE_opengl)
- #target_sources(affine PUBLIC
+ #target_sources(affine PRIVATE
#../shared/fbopaintdevice.cpp ../shared/fbopaintdevice.h
#)
- #target_link_libraries(affine PUBLIC
+ #target_link_libraries(affine PRIVATE
#Qt6::OpenGL
#)
#endif()