summaryrefslogtreecommitdiffstats
path: root/examples/widgets/painting/painterpaths/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/painting/painterpaths/CMakeLists.txt')
-rw-r--r--examples/widgets/painting/painterpaths/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/examples/widgets/painting/painterpaths/CMakeLists.txt b/examples/widgets/painting/painterpaths/CMakeLists.txt
new file mode 100644
index 0000000000..13dd321a52
--- /dev/null
+++ b/examples/widgets/painting/painterpaths/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Generated from painterpaths.pro.
+
+#####################################################################
+## painterpaths Binary:
+#####################################################################
+
+add_qt_executable(painterpaths
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/painting/painterpaths"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/painting/painterpaths"
+ SOURCES
+ main.cpp
+ renderarea.cpp renderarea.h
+ window.cpp window.h
+ LIBRARIES
+ Qt::Widgets
+ painting_shared # special case
+)
+
+## Scopes:
+#####################################################################
+
+extend_target(painterpaths CONDITION UNIX AND NOT APPLE_OSX AND NOT HAIKU AND NOT INTEGRITY AND NOT VXWORKS
+ LIBRARIES
+ m
+)