summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/CMakeLists.txt24
1 files changed, 7 insertions, 17 deletions
diff --git a/examples/widgets/tools/CMakeLists.txt b/examples/widgets/tools/CMakeLists.txt
index 022f4a2b8f..a5ec5c4a3e 100644
--- a/examples/widgets/tools/CMakeLists.txt
+++ b/examples/widgets/tools/CMakeLists.txt
@@ -1,18 +1,8 @@
-# Generated from tools.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-add_subdirectory(completer)
-add_subdirectory(customcompleter)
-if(QT_FEATURE_translation) # special case
- add_subdirectory(i18n)
-endif()
-add_subdirectory(regularexpression)
-add_subdirectory(settingseditor)
-add_subdirectory(styleplugin)
-add_subdirectory(treemodelcompleter)
-add_subdirectory(undo)
-add_subdirectory(undoframework)
-
-if(QT_FEATURE_library) # special case
- add_subdirectory(echoplugin)
- add_subdirectory(plugandpaint) # special case
-endif()
+qt_internal_add_example(completer)
+qt_internal_add_example(customcompleter)
+qt_internal_add_example(regularexpression)
+qt_internal_add_example(treemodelcompleter)
+qt_internal_add_example(undoframework)